$re = '/^[ \t]+/m';
$str = ' A new line begins
Another line begins
Here\'s another';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;