using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\<th[^\>]*?\>|\<td[^\>]*?\>)(?:\r?\n)?([\s\S]*?)(?:\r?\n)?(\<\/\\1\>)";
string input = @"<table>
<tr>
<th> test th </th>
</tr><tr>
<td> test td </td>
</tr>
</table>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}