using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\(\d+(?:\.\d+)?,\d+(?:\.\d+)?\))+$";
string input = @"(2.2,2.0321312)(1,12)(3.12,12.1)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}