$re = '/^(?:\(\d+(?:\.\d+)?,\d+(?:\.\d+)?\))+$/m';
$str = '(2.2,2.0321312)(1,12)(3.12,12.1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);