using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\/\/([^:\/\s]+)";
string input = @"https://www.google.com/
https://www.google.com/search?q=Regular+Expressions&num=1000
https://google.com:80";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}