package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http(s)?:\/\/[^\s]*\x{200b}[^\s]*`)
var str = `https://prime-link.net/kKiHr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}