import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".{8}#[\\w\\d\\?!]{15}";
final String string = "FF_WE_GE#Ww!00NnFfHH22Bndcth52?D\n"
+ "asdFF_WE_GE#Ww!00NnFfHH22Bndcth52?D";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}