$re = '/\b\w(?:[\w\s]{19,}?(?!\S)|.*)/m';
$str = 'this is an input example of one sentence that contains a bit of words and must be split';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);