re = /\b\w(?:[\w\s]{19,}?(?!\S)|.*)/m
str = 'this is an input example of one sentence that contains a bit of words and must be split'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end