#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[.]*\/([\-\w]*?\-\d+)"
Local $sString = "feature/ABC-123-test-message" & @CRLF & _
"Improvement/XYZ-ABC-321-Crazy-Name" & @CRLF & _
"abc-123-do-it" & @CRLF & _
"simple-branch-name" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")