// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[.]*\/([\-\w]*?\-\d+)").unwrap();
let string = "feature/ABC-123-test-message
Improvement/XYZ-ABC-321-Crazy-Name
abc-123-do-it
simple-branch-name
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}