#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?<name>\w+)\s*\(\K" & @CRLF & _
"(?<e>" & @CRLF & _
" [^()]+" & @CRLF & _
" |" & @CRLF & _
" [^()]*" & @CRLF & _
" \((?&e)\)" & @CRLF & _
" [^()]*" & @CRLF & _
")*" & @CRLF & _
"(?=\))"
Local $sString = "foo(() ((hello) world))" & @CRLF & _
"bar (hello world!)" & @CRLF & _
"baz((()))" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")