#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^=]+\s=\s(?:(?!Hex-STRING:)[^:])*:?\s*(?<value_v2c>(?:Hex-STRING: )?[^=]+?)(?: -|$)"
Local $sString = ".1.3.6.1.2.1.1.3.0 = Timeticks: (2624594000) 303 days, 18:32:20.00 - .1.3.6.1.6.3.1.1.4.1.0 = OID: .1.3.6.1.4.1.14179.2.6.3.39 - .1.3.6.1.4.1.14179.2.2.1.1.1.84.74.0.200.115.112 = Hex-STRING: 54 4A 00 C8 73 70 - .1.3.6.1.4.1.14179.2.2.2.1.1.84.74.0.200.115.112.0 = INTEGER: 0 - .1.3.6.1.4.1.14179.2.2.1.1.3.0 = STRING: "NJTHAP027""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")