use strict;
my $str = '1 hinge 2pk
1 Se wall cabinet
4 door 15x40"';
my $regex = qr/^\d+\h+Se\b/mp;
my $subst = '\\n$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";