$re = '/^(?!.*\d{2,})[a-zA-Z0-9]*[a-zA-Z][a-zA-Z0-9]*$/m';
$str = 'love
i2p
111
1ab
ok
luana
okkffkkfkfkkfkkkfkfkfkkfkfkfkf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);