# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[[^]]*#\d{2}\b[^]]*\]//gm;t' <<< "12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else] 12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else].
would result in
12345 one two words [2025/02/25] #15 turtles ."