use strict;
my $str = '12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else] 12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else].
would result in
12345 one two words [2025/02/25] #15 turtles .';
my $regex = qr/\[[^]]*#\d{2}\b[^]]*\]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";