$re = '/\[[^]]*#\d{2}\b[^]]*\]/m';
$str = '12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else] 12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else].
would result in
12345 one two words [2025/02/25] #15 turtles .';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;