import re
regex = re.compile(r"\[[^]]*#\d{2}\b[^]]*\]", flags=re.MULTILINE)
test_str = ("12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else] 12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else].\n\n"
"would result in\n\n"
"12345 one two words [2025/02/25] #15 turtles .")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)