package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\d+.*?)engineer`)
var str = `abc mysql 23 rufos kanso engineer
def grusol defno 1635 minos kalopo, ruso engineer okas puno"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}