$re = '/,(?![^,]+"\s*,)\s*/m';
$str = '1,2,3,4,5,"one, two", 6, 7, "three, four", 8, 9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);