import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.+href=['\"]((:?https?:\\/\\/(?:www\\.)?site\\.ru)?(\\/?catalog\\/.+))['\"].+>";
final String string = "<a href=\"catalog/###/###/about.html\">About</a>\n"
+ "<a href=\"/catalog/###/###/about.html\">About</a>\n"
+ "<a class=\"go-link\" href=\"http://site.ru/catalog/###/###/about.html\">About</a>\n"
+ "<a href=\"http://www.site.ru/catalog/###/###/about.html\">About</a>\n"
+ "<a href=\"https://www.site.ru/catalog/###/###/about.html\">About</a>\n"
+ "<a href=\"matalog/###/###/about.html\">About</a><a href=\"https://www.site.ru/news/###/###/###/###/SAMASSILKA.html\" target=\"_blank\">GOGO</a>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}