re = /[\s-]+/m
str = ' Word - Another Wow --- ----- ------ ---- --- look-at-that '
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result