// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Vous\savez\srecu\sun\stransfert\sde\s(?P<amount>\d+)FCFA\sde\s(?P<sender_name>.*)\s\((?P<sender_phone>\d+)\)\sle\s(?P<when>.*?)\..*ID.*transaction\s.*?(?P<transaction_id>\d+)\.*").unwrap();
let string = "Vous avez recu un transfert de 12300FCFA de Comlan Louis Barthelemy Djihoulande (22997870329) le 2023-06-25 11:26:57. Reference: d. Nouveau solde: 20120 FCFA. ID de la transaction : 5041378775..";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}