Vousthe literal text Vous (case sensitive) \sa Unicode whitespace character
avezthe literal text avez (case sensitive) \sa Unicode whitespace character
recuthe literal text recu (case sensitive) \sa Unicode whitespace character
unthe literal text un (case sensitive) \sa Unicode whitespace character
transfertthe literal text transfert (case sensitive) \sa Unicode whitespace character
dethe literal text de (case sensitive) \sa Unicode whitespace character
Group amount(?P<amount>\d+) \d+a Unicode decimal digit, repeated at least once
FCFAthe literal text FCFA (case sensitive) \sa Unicode whitespace character
dethe literal text de (case sensitive) \sa Unicode whitespace character
Group sender_name(?P<sender_name>.*) .*any Unicode character (except for line terminators), repeated any number of times
\sa Unicode whitespace character
\(the literal ( (4010 / 508 / 2816)
Group sender_phone(?P<sender_phone>\d+) \d+a Unicode decimal digit, repeated at least once
\)the literal ) (4110 / 518 / 2916)
\sa Unicode whitespace character
lethe literal text le (case sensitive) \sa Unicode whitespace character
.*?any Unicode character (except for line terminators), repeated any number of times
\.the literal . (4610 / 568 / 2E16)
.*any Unicode character (except for line terminators), repeated any number of times
IDthe literal text ID (case sensitive) .*any Unicode character (except for line terminators), repeated any number of times
transactionthe literal text transaction (case sensitive) \sa Unicode whitespace character
.*?any Unicode character (except for line terminators), repeated any number of times
Group transaction_id(?P<transaction_id>\d+) \d+a Unicode decimal digit, repeated at least once
\.*the literal . (4610 / 568 / 2E16) , repeated any number of times
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string