import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Sec\\.\\s*\\S+.*\\n.*\\D.*\\D.*|Acts*\\D\\s.*)";
final String string = "Sec. 11.001. DEFINITIONS. In this chapter:\n"
+ "(1) \"State\" means the State of Texas.\n"
+ "(2) \"Land office\" means the General Land Office.\n"
+ "(3) \"Commissioner\" means the Commissioner of the General Land Office.\n\n"
+ "Acts 1977, 65th Leg., p. 2349, ch. 871, art. I, Sec. 1, eff. Sept. 1, 1977.\n\n\n"
+ "SUBCHAPTER B. TERRITORY AND BOUNDARIES OF THE STATE\n\n"
+ "Sec. 11.011. VACANT AND UNAPPROPRIATED LAND. So that the law relating to the public domain may be brought together, the following extract is taken from the joint resolutions of the Congress of the United States relating to the annexation of Texas to the United States, which was approved June 23, 1845: \"Said State, when admitted into the Union, . . . shall also retain all the vacant and unappropriated lands lying within its limits, to be applied to the payment of debts and liabilities of said Republic of Texas, and the residue of said lands, after discharging said debts and liabilities, to be disposed of as said State may direct. . . .\"\n\n"
+ "Acts 1977, 65th Leg., p. 2349, ch. 871, art. I, Sec. 1, eff. Sept. 1, 1977.\n\n\n"
+ "Sec. 11.0111. LOCATION OF COASTAL BOUNDARIES. (a) The commissioner shall:\n"
+ "(1) have the area between the coastline of the Gulf of Mexico and the Three Marine League line compiled and platted; and\n"
+ "(2) locate and set the boundary lines between the coastal counties from the coastline to the Three Marine League line.\n"
+ "(b) The commissioner shall locate and set the boundary lines between the counties from the coastline to the Three Marine League line in accordance with established engineering practice.\n"
+ "(c) The legal description of the boundary lines set between the counties from the coastline to the continental shelf shall be filed and recorded in the office of the county clerk of the affected county.\n\n"
+ "Added by Acts 2003, 78th Leg., ch. 1091, Sec. 30, eff. June 20, 2003.\n\n\n"
+ "Sec. 11.012. GULFWARD BOUNDARY OF TEXAS. (a) The gulfward boundary of the State of Texas is the boundary determined in and pursuant to the decision of the United States Supreme Court in Texas v. Louisiana, 426 U.S. 465 (1976).\n"
+ "(b) The State of Texas has full sovereignty over the water, the beds and shores, and the arms of the Gulf of Mexico within its boundaries as provided in Subsection (a) of this section, subject only to the right of the United States to regulate foreign and interstate commerce under Article I, Section 8 of the United States Constitution, and the power of the United States over admiralty and maritime jurisdiction under Article III, Section 2 of the United States Constitution.\n"
+ "(c) The State of Texas owns the water and the beds and shores of the Gulf of Mexico and the arms of the Gulf of Mexico within the boundaries provided in this section, including all land which is covered by the Gulf of Mexico and the arms of the Gulf of Mexico either at low tide or high tide.\n"
+ "(d) None of the provisions of this section may be construed to relinquish any dominion, sovereignty, territory, property, or rights of the State of Texas previously held by the state.\n\n"
+ "Acts 1977, 65th Leg., p. 2349, ch. 871, art. I, Sec. 1, eff. Sept. 1, 1977.\n\n\n"
+ "Sec. 11.013. GULFWARD BOUNDARIES OF COUNTIES, CITIES, TOWNS, OR VILLAGES. (a) The gulfward boundary of each county located on the coastline of the Gulf of Mexico is the Three Marine League line as determined by the United States Supreme Court.\n"
+ "(b) The area in the extended boundaries of the counties as provided in this section becomes a part of the public free school land and is subject to the constitutional and statutory provisions of this state pertaining to the use, distribution, sale, and lease of public free school land in this state.\n"
+ "(c) The gulfward boundaries of any city, town, or village created and operating under the general laws of the State of Texas shall not be established or extended by incorporation or annexation more than 5,280 feet gulfward beyond the coastline. The governing body of such a city, town, or village may, by ordinance, extend the municipal boundaries up to 5,280 feet gulfward. Any inclusion of territory in any such city, town, or village more than 5,280 feet gulfward beyond the coastline is void. The term \"coastline\" as used in this subsection means the line of mean low tide along that portion of the coast which is in direct contact with the open Gulf of Mexico. The term \"city, town, or village created and operating under the general laws of the State of Texas\" shall not include any city operating under a home-rule charter.\n"
+ "If any such general-law city, town, or village has heretofore been established by incorporation or attempted incorporation more than 5,280 feet gulfward beyond the coastline, the corporate existence of such general-law city, town, or village is in all things validated, ratified, approved, and confirmed.\n"
+ "The boundaries of such general-law city, town, or village, including the gulfward boundaries to the extent of 5,280 feet gulfward beyond the coastline, are in all things validated, ratified, approved, and confirmed and shall not be held invalid by reason of the inclusion of more territory than is expressly authorized in Article 971, Revised Civil Statutes of Texas, 1925, as amended, or by reason of the inclusion of territory other than that which is intended to be used for strictly town or city purposes as required by Section 7.002, Local Government Code or by reason of not constituting a city, town, or village.\n"
+ "Neither this Act nor the general laws nor the special laws of the state shall have the effect of validating, ratifying, approving, or confirming the inclusion of territory in any such general-law city, town, or village more than 5,280 feet gulfward beyond the coastline.\n"
+ "If for any reason it should be determined by any court of competent jurisdiction that any such general-law city, town, or village has heretofore been incorporated in violation of the laws of the state in effect as of the date of such incorporation or is invalid, the corporate boundaries of any such general-law city, town, or village shall be revised and reformed to exclude all territory more than 5,280 feet gulfward of the coastline.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}