$re = '/import(?:["\'\s]*([\w*{}\n, ]+)from\s*)?["\'\s].*([@\w/_-]+)["\'\s].*/';
$str = 'import React from "react"
import { Field } from "redux-form"
<MenuItem value="^$" primaryText="Não exibir importados" />
<MenuItem value="\\\\w+" primaryText="Exibir importados" />
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);