use strict;
my $str = '1';
my $regex = qr/\b([0-9]+)\b/p;
my $subst = '0$1~01234567890';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";