import Foundation
let pattern = #"\b([0-9]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$1~01234567890"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)