import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((\\r?\\n|\\s)*[A-Za-z0-9+\\/]){4})*(((\\r?\\n|\\s)*[A-Za-z0-9+\\/]){2}((\\r?\\n|\\s)*=){2}|((\\r?\\n|\\s)*[A-Za-z0-9+\\/]){3}((\\r?\\n|\\s)*=){1})?";
final String string = "abdcdd fijfokkkmAS/+=\n\n"
+ "assdoifjfjidodijfjjjDDD";
final String subst = "<<<$0>>>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}