const regex = /(((\r?\n|\s)*[A-Za-z0-9+\/]){4})*(((\r?\n|\s)*[A-Za-z0-9+\/]){2}((\r?\n|\s)*=){2}|((\r?\n|\s)*[A-Za-z0-9+\/]){3}((\r?\n|\s)*=){1})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((\\r?\\n|\\s)*[A-Za-z0-9+\\\/]){4})*(((\\r?\\n|\\s)*[A-Za-z0-9+\\\/]){2}((\\r?\\n|\\s)*=){2}|((\\r?\\n|\\s)*[A-Za-z0-9+\\\/]){3}((\\r?\\n|\\s)*=){1})?', 'gm')
const str = `abdcdd fijfokkkmAS/+=
assdoifjfjidodijfjjjDDD`;
const subst = `<<<$0>>>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);