import Foundation
let pattern = #"(((\r?\n|\s)*[A-Za-z0-9+\/]){4})*(((\r?\n|\s)*[A-Za-z0-9+\/]){2}((\r?\n|\s)*=){2}|((\r?\n|\s)*[A-Za-z0-9+\/]){3}((\r?\n|\s)*=){1})?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abdcdd fijfokkkmAS/+=
assdoifjfjidodijfjjjDDD
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<<<$0>>>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)