const regex = /\b(\d+)\s*:\s*(\d+)\s*([ap])\.\s*m\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)\\s*:\\s*(\\d+)\\s*([ap])\\.\\s*m\\.', 'gm')
const str = `2:0 a. m.
2:0 p. m.
3:0 p. m.
3:0p.m.
2:0 am`;
const subst = `$1:$2 $3m`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);