#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(S)([0-9])"
Local $sString = "TRS34" & @CRLF & _
"MMH22" & @CRLF & _
"GFSR104" & @CRLF & _
"GS23" & @CRLF & _
"RRTM55" & @CRLF & _
"P3" & @CRLF & _
"S4"
Local $sSubst = "\1-\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)