const regex = /(S)([0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(S)([0-9])', 'gm')
const str = `TRS34
MMH22
GFSR104
GS23
RRTM55
P3
S4`;
const subst = `\1-\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);