package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ (JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC) (MON|TUE|WED|THU|FRI|SAT|SUN) (19|20)\d\d $`)
var str = ` FEB MON 2023 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}