#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Processo\sNº\s[a-zA-Z]{5,9}-[0-9]{7}-[0-9]{2}.[0-9]{4}.[0-9]{1}.[0-9]{2}.[0-9]{4}[^a-zA-Z]"
Local $sString = "Precatórios e RPV" & @CRLF & _
"AVENIDA DE MARQUES SAO VICENTE , 235, 19 andar - Bloco B," & @CRLF & _
"VARZEA DA BARRA FUNDA, SAO PAULO/SP - CEP: 01139-001" & @CRLF & _
"- secprecatorio@trtsp.jus.br" & @CRLF & _
"Destinatário: PEDRO CARLOS LUCAS" & @CRLF & _
"INTIMAÇÃO - Processo PJe" & @CRLF & _
"Processo: 0148400-36.2009.5.02.0041 - Processo PJe" & @CRLF & _
"Autor: PEDRO CARLOS LUCAS" & @CRLF & _
"Réu: FUNDACAO PRO-SANGUE HEMOCENTRO DE SAO PAULO" & @CRLF & _
"Fica V. Sª. intimado(a) dos id’s:" & @CRLF & _
"SAO PAULO/SP, 09 de novembro de 2022." & @CRLF & _
"SAO PAULO/SP, 09 de novembro de 2022." & @CRLF & _
"ENIO MARQUES" & @CRLF & _
"Servidor" & @CRLF & _
"Processo Nº ATOrd-0148400-36.2009.5.02.0041" & @CRLF & _
"RECLAMANTE PEDRO CARLOS LUCAS" & @CRLF & _
"ADVOGADO Marcia Regina Covre(OAB:" & @CRLF & _
"108818/SP)" & @CRLF & _
"RECLAMADO FUNDACAO PRO-SANGUE" & @CRLF & _
"HEMOCENTRO DE SAO PAULO" & @CRLF & _
"ADVOGADO MARINA MEGALE(OAB: 221085/SP)" & @CRLF & _
"ADVOGADO CAROLINA KIRALY SANCHEZ(OAB:" & @CRLF & _
"278463/SP)" & @CRLF & _
"ADVOGADO JOSE BARBUTO NETO(OAB:" & @CRLF & _
"207975/SP)" & @CRLF & _
"Intimado(s)/Citado(s): Processo Nº ATOrd-0148400-36.2009.5.02.0042" & @CRLF & _
" - FUNDACAO PRO-SANGUE HEMOCENTRO DE SAO PAULO" & @CRLF & _
" PODER JUDICIÁRIO" & @CRLF & _
" JUSTIÇA DO" & @CRLF & _
"PODER JUDICIÁRIO FEDERAL" & @CRLF & _
"Justiça do Trabalho - 2ª Região" & @CRLF & _
"Precatórios e RPV" & @CRLF & _
"AVENIDA DE MARQUES SAO VICENTE , 235, 19 andar - Bloco B,VARZEA DA BARRA FUNDA, SAO PAULO/SP - CEP: 01139-001" & @CRLF & _
"- secprecatorio@trtsp.jus.br" & @CRLF & _
"Destinatário: FUNDACAO PRO-SANGUE HEMOCENTRO DE SAO" & @CRLF & _
"PAULO" & @CRLF & _
"INTIMAÇÃO - Processo PJe" & @CRLF & _
"Processo: 0148400-36.2009.5.02.0041 - Processo PJe" & @CRLF & _
"Autor: PEDRO CARLOS LUCAS" & @CRLF & _
"Réu: FUNDACAO PRO-SANGUE HEMOCENTRO DE SAO PAULO" & @CRLF & _
"Fica V. Sª. intimado(a) dos id’s:778674a" & @CRLF & _
"SAO PAULO/SP, 09 de novembro de 2022." & @CRLF & _
"SAO PAULO/SP, 09 de novembro de 2022." & @CRLF & _
"ENIO MARQUES" & @CRLF & _
"Servidor" & @CRLF & _
"Processo Nº ATOrd-0076600-43.2003.5.02.0045" & @CRLF & _
"RECLAMANTE PAULO ROBERTO VENDRAMI" & @CRLF & _
"ADVOGADO JAIZA DOMINGAS" & @CRLF & _
"GONCALVES(OAB: 55633/SP)" & @CRLF & _
"RECLAMADO DEPARTAMENTO AEROVIARIO DO" & @CRLF & _
"Processo Nº ATOrd-0148400-36.2009.5.02.0043Lula"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")