using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:remind me ).*? (to|that|about|its|it's)? ?(.*)$";
string input = @"remind me in 24 hours test
remind me in 24 hours to test
remind me to test
E.g. These strings would work with your current pattern
two spaces after 'remind me' where the group fits in:
^(?:remind me ).*? (to....
^ ^
remind me to test
remind me blabla to test
one or three or more, no:
remind me to test
remind me to test
remind me bla bla to test
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}