import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:remind me ).*? (to|that|about|its|it's)? ?(.*)$";
final String string = "remind me in 24 hours test\n"
+ "remind me in 24 hours to test\n"
+ "remind me to test\n\n"
+ "E.g. These strings would work with your current pattern\n"
+ "two spaces after 'remind me' where the group fits in:\n"
+ "^(?:remind me ).*? (to....\n"
+ " ^ ^\n"
+ "remind me to test\n"
+ "remind me blabla to test\n\n"
+ "one or three or more, no:\n"
+ "remind me to test\n"
+ "remind me to test\n"
+ "remind me bla bla to test\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}