# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:remind me ).*? (to|that|about|its|it's)? ?(.*)$"
test_str = ("remind me in 24 hours test\n"
"remind me in 24 hours to test\n"
"remind me to test\n\n"
"E.g. These strings would work with your current pattern\n"
"two spaces after 'remind me' where the group fits in:\n"
"^(?:remind me ).*? (to....\n"
" ^ ^\n"
"remind me to test\n"
"remind me blabla to test\n\n"
"one or three or more, no:\n"
"remind me to test\n"
"remind me to test\n"
"remind me bla bla to test\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.