// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:remind me ).*? (to|that|about|its|it's)? ?(.*)$").unwrap();
let string = "remind me in 24 hours test
remind me in 24 hours to test
remind me to test
E.g. These strings would work with your current pattern
two spaces after 'remind me' where the group fits in:
^(?:remind me ).*? (to....
^ ^
remind me to test
remind me blabla to test
one or three or more, no:
remind me to test
remind me to test
remind me bla bla to test
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}