# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\S\r\n](?=[0-9])//g;t' <<< "10 000,00 EUR
1 000 000,00 EUR"