#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^\S\r\n](?=[0-9])"
Local $sString = "10 000,00 EUR" & @CRLF & _
"1 000 000,00 EUR"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)