using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\S\r\n](?=[0-9])";
string substitution = @"";
string input = @"10 000,00 EUR
1 000 000,00 EUR";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}