re = /[^\S\r\n](?=[0-9])/
str = '10 000,00 EUR
1 000 000,00 EUR'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result