import Foundation
let pattern = #"[^\S\r\n](?=[0-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
10 000,00 EUR
1 000 000,00 EUR
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)