package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)select\s+([\w ,]+)\s+from\s+(\w+)(?:\s+where([\w =]+))?`)
var str = `select color, year from car where color = blue and year = 2002
select color, year from car`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}