import re
regex = re.compile(r"&(#[a-fA-F0-9]{6})((?:-#[a-fA-F0-9]{6})+)((?:&[k-oK-OrR])+)?(.*?)(?=(&#[a-fA-F0-9]{6}|&[a-fA-Fk-oK-OrR0-9])|$)", flags=re.MULTILINE)
test_str = "𛈇-#222222-#333333&lTesting text&f"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")