# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((<)(\/|)([a-zA-Z-Z0-9]+))"
test_str = ("<!-- Comments Testing -->\n"
"<div id=\"page\"><div id=\"header\"><h1><a href=\"#\">Burger Pointer</a></h1><ul class=\"left\"><li><a href=\"#\">Menu</a></li><li><a href=\"#\">Location</a></li><li><a href=\"#\">About Us</a></li><li><a href=\"#\">BP Gear</a></li></ul></div></div>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.