# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((<)(\\/|)(?!a|h1)([a-zA-Z0-9]+))/\n\1/g;t' <<< "<!-- Comments Testing -->
<div id=\"page\"><div id=\"header\"><h1><a href=\"#\">Burger Pointer</a></h1><ul class=\"left\"><li><a href=\"#\">Menu</a></li><li><a href=\"#\">Location</a></li><li><a href=\"#\">About Us</a></li><li><a href=\"#\">BP Gear</a></li></ul></div></div>"